На главную... Продукты | Технологии | Классификаторы | Проекты | Скачать | Цены| Форум | Статьи | Обучение | Контакты

Настройка авторизации в Windows

Поиск  Пользователи  Правила  Войти
Форум » Серверные приложения » GIS WebServer
Страницы: 1
RSS
Настройка авторизации в Windows, Не открывается страница WebServer
 
Добрый день!
В целях ознакомления решил установить последние версии продуктов GISWebServiceSE и GISwebServerSE под ОС Windows.
GISWebServiceSE установился, тип авторизация согласно руководству digest установлен.
В файле adminlist.php параметром авторизации установлено значение 1.
Устанавливаю GISwebServerSE - пытаюсь зайти на страницу.
На ней выводится сообщение
"Authentification types of the web server and application are not match"
В файле authorization.php написано что это сообщение выводится если параметр AuthType равен 0 или больше 4. И в этом файле нет присвоения параметра для AuthType
В подгружаемом в authorization.php файле util.php видно что AuthType берется из файла настроек xml.
В файле C:\ProgramData\Panorama\GISWebServerSE\config.xml - нет в нужном виде задания AuthType.
Подскажите пожалуйста, где необходимо поправить параметр?
 
В GIS WebServer SE тип аутентификации настраивается через админку, на странице "Параметры".

P.S. Прежде чем менять тип аутентификации, убедитесь, что все корректно работает при обычной проверке подлинности.
 
Тогда я немножко изменю свой вопрос - как мне в текущей ситуации попасть в админку?
Какие настройки необходимо произвести над GISWebServerSE, чтобы он корректно работал на компьютере с уже установленным и настроенным на Digest авторизацию GISWebServiceSE?
 
Измените в файле config.xml значение <UsersList AuthType="0"> на <UsersList AuthType="1">
 
Доброе утро
В файле C:\ProgramData\Panorama\GISWebServerSE\config.xml - я изменил значение <UsersList AuthType="0"> на <UsersList AuthType="1">
Но это ничего не изменило - сообщение всё также выводится
"Authentification types of the web server and application are not match"
 
В файле C:\ProgramData\Panorama\GISWebServerSE\config.xml измените  значение <UsersList AuthType="0"> на <UsersList  AuthType="2"> (системная или PAM авторизация)
 
Добрый день!
Изменил параметр UsersList  AuthType на 2.
При открытии страницы - как положено вышло сообщение авторизации.
Авторизовался - На странице баннер GIS WebAdministrator, под ним три кнопки, и еще чуть ниже сообщение "У вас нет разрешения на доступ к панели администратора ..."
Я подумал, что это потому что мой пользователь (Digest авторизация) не добавлен в список администраторов GISWebServerSE.
В файле C:\ProgramData\Panorama\GISWebServerSE\config.xml  в <UsersList> была добавлена строка  <User Login="Roma" Password="7591d255d631ca00908b0345aa27d90c" RoleName="ADMINISTRATOR" Admin="1" Group="0"/>
Но это ничего не изменило.
Затем я решил добавить пользователя с логином admin(который согласно руководству, встроенный администратор GISWebServerSe) в файл ".htdigestpasswd" и зайти под ним.
Пользователя я добавил, но после авторизации у меня снова выходит сообщение   "У вас нет разрешения на доступ к панели администратора ..."
Подскажите пожалуйста, что я делаю не так?
 
Необходимо убедиться, что значение параметра AuthName, указанное при настройке Digest проверки подлинности (при использовании Apache) совпадает со значениями параметров $realm и $arealm в файле config.php (для панели карт и панели администрирования соответственно).
 
Открыл файл config.php  и присвоил обоим параметрам значение "Private"  и сохранил.
В файле настроек Apache - согласно руководству еще GISWebServiceSE было прописано
Код
<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
   Satisfy all
    AuthType Digest
    AuthName "Private"
    AuthUserFile C:/server/apache/htdocs/.htdigestpasswd
    Require valid-user
</Directory> 

Файл htdigestpasswd имеет запись

Код
 Roma:Private:7591d255d631ca00908b0345aa27d90c

Открываю снова GISWebServerSE в браузере -по прежнему при попытке войти в настройки выходит сообщение "У вас нет разрешения на доступ к панели администратора ..."

 
Для пользователя Roma должен быть установлен атрибут Admin="1" в config.xml, соответствующий установленному флажку "Администрирование"

Изменено: Егор Помозов - 19.06.2018 10:15:45
Страницы: 1
Читают тему (гостей: 1)



© КБ Панорама, 1991-2020

Регистрируясь или авторизуясь на форуме, Вы соглашаетесь с Политикой конфиденциальности