На главную... Продукты | Технологии | Классификаторы | Проекты | Скачать | Цены| Форум | Статьи | Обучение | Контакты

Установка GIS Webservice

Поиск  Пользователи  Правила  Войти
Форум » Серверные приложения » GIS WebService
Страницы: 1 2 След.
RSS
Установка GIS Webservice, Несоответствие документации и последних версий сервера Apache и интерпретатора PHP
 
Здравствуйте!
Выполняем установку GIS Webservice 12.2 и GIS Webserver 4.5.
Операционная система Windows Server 2012 R2, Apache 2.4.39-win64-VC15, php 7.3.4-nts-Win32-VC15-x64 (Thread Safe).
Ваши программные продукты устанавливаем в папку c:\Apache24\htdocs\

Просим выслать настройки (изменения) для корректной работы WEB сервиса (-ра) для файлов конфигураций httpd.conf и php.ini-production. Текущие файлы настроек отправил на почту panorama@gisinfo.ru с ссылкой на эту тему.

 
Цитата
Николай написал:
Здравствуйте!
Выполняем установку GIS Webservice 12.2 и GIS Webserver 4.5.
Операционная система Windows Server 2012 R2, Apache 2.4.39-win64-VC15, php 7.3.4-nts-Win32-VC15-x64 (Thread Safe).
Ваши программные продукты устанавливаем в папку c:\Apache24\htdocs\

Просим выслать настройки (изменения) для корректной работы WEB сервиса (-ра) для файлов конфигураций httpd.conf и php.ini-production. Текущие файлы настроек отправил на почту  panorama@gisinfo.ru  с ссылкой на эту тему.
Ответ выслали по электронной почте.
 
Цитата
Елена Кузнецова написал:
Цитата
Ответ выслали по электронной почте
Спасибо, будем пробовать.
 
Здравствуйте!
После установки GIS WEBServer до и после полученных от вас файлов настроек httpd.conf и php.ini возникает проблема, как на скриншоте
Файл util.php отправил на почту panorama@gisinfo.ru с ссылкой на эту тему.
Изменено: Николай - 11.04.2019 16:42:37
 
Цитата
Николай написал:
Здравствуйте!
После установки GIS WEBServer до и после полученных от вас файлов настроек httpd.conf и php.ini возникает проблема, как на  скриншоте
Файл util.php отправил на почту  panorama@gisinfo.ru  с ссылкой на эту тему.
Предлагаем ознакомится с технической документацией (представлена на нашем сайте, раздел Скачать - Документация).
ПРОГРАММНОЕ ИЗДЕЛИЕ GIS WEBSERVER. (GIS WebServer SE)
Руководство системного программиста. ПАРБ.00165-01 32 01
3.2.1 Подключение PHP как модуля Apache
3.6.1 Настройка веб-сервера IIS
http://gistoolkit.ru/download/doc/giswebserverseadmin.pdf
 
Цитата
Елена Кузнецова написал:
Предлагаем ознакомится с технической документацией (представлена на нашем сайте, раздел Скачать - Документация).ПРОГРАММНОЕ ИЗДЕЛИЕ GIS WEBSERVER. (GIS WebServer SE) Руководство системного программиста. ПАРБ.00165-01 32 01
Большое спасибо за предложение скачать документацию.
Только она у вас не соответствует текущим версиям!!! :(
Именно из-за этого и появилась данная тема.

Нас интересует ответ на конкретный вопрос, как исправить ошибки указанные на скриншоте в предыдущем сообщении.

Убедительная просьба, не задерживать ваш ответ на долгий строк.
 
Вся документация соответствует выпущенным версиям! Ссылка на документацию соответствует версии GIS WebServer SE 4.5, выложенной на сайте. Если у Вас другая версия, то документация к ней находится в папке c:\Program Files\Panorama\GISWebServerSE\doc\, или по ссылке из самого приложения.

Ошибки, указанные на скриншоте, вызваны использованием PHP 7-ой версии, которая не обеспечивает преемственности с предыдущими версиями PHP. Поддержка PHP 7 будет реализована в следующей версии GIS WebServer SE, которая выйдет в ближайшее время.
Для работы текущей версии GIS WebServer SE необходим PHP в пределах 5-ой версии.
 
Цитата
admin написал:
Поддержка PHP 7 будет реализована в следующей версии GIS WebServer SE
Проверял у себя (на тестовой версии 4.5), работает! 8)  Правда, Веб-сервер используем IIS. И что радует, что переход на PHP 7 х64 позволил работать (при обновлении драйверов, конечно) и с СУБД MS SQL Server :-). Ждем выход официальной версии.
Изменено: Vitaliy Belenkov - 12.04.2019 12:33:45
 
У меня работает в следующей конфигурации:
Windows 10
GIS WebService SE 12.2
GIS WebServer SE 4.5
Apache/2.4.39 (Win64) PHP/7.2.17

PHP установлен как модуль Apache (это важно, иначе - глюки).
Apache используется (как рекомендует сам Apache) из проекта Apache Lounge.

Технически все работает - ошибок во всяком случае в логах нет.

Могу прислать конфиг php.ini и httpd.conf.
 
Да, еще забыл дописать - ошибки подобной как на скриншоте не возникало.
И да, документация в части настройки Apache очень скудная и трактуется двояко.
Поясню - фраза "Для настройки PHP как модуля Apache нужно сделать то-то и то-то". Из этой фразы не следует, что PHP обязательно нужно настроить как модуль Apache.
Страницы: 1 2 След.
Читают тему (гостей: 1)



© КБ Панорама, 1991-2021

Регистрируясь или авторизуясь на форуме, Вы соглашаетесь с Политикой конфиденциальности